parte 1: Configuración básica ADSL con IP dinámica

16 de marzo de 2008

En esta parte configuraremos la interfaz WAN y la LAN desde cero, y dejaremos el router listo para poder navegar desde la LAN interna. Como requisitos necesitaremos tener listo los datos de conexión ADSL del proveedor.

+ Nos conectamos a la consola del router y vemos que arranca correctamente. Intentamos ver que el firmware se descomprimime bien, que arranca y miramos si hay algun tipo de configuración ya hecha.
+ Borramos la configuración que pueda tener el router pulsado sobre reset (botón de la parte trasera) y sin soltar, encendemos el router.
+ Después de botar nos dirá que no hay ningun tipo de configuración y que solo hay un usuario cisco/cisco creardo para comenzar a configurar.
+ Entramos como cisco/cisco y miramos las características del router. Primero hacemos un "show run" para ver la configuración de fábrica y luego un "show version" para ver el IOS que tiene el router y la memoria flash/ram que disponemos. Con el primer comando ya vemos que nos ha puesto en la LAN del router la 10.10.10.1 y que esta activado el DHCP. Con el segundo comando vemos que tenemos la versión 12.4 del IOS.
+ Configuramos un usuario administrador con privilegios máximos, el hostname y la fecha:

# conf term
(config)# hostname cisco857
(config)# # username admin privilege 15 secret 0 123456
(config)# # no username cisco
(config)# # no banner login
# exit
# clock set 22:45:00 March 14 2008
# copy run start
# reload
+ Es hora de configurar la interfaz interna, la LAN. Dado tendremos dos interfaces (una ethernet y otra inlambrica) que estaran dentro de la red interna, crearemos una interfaz virtual con la IP (por ejemplo) 192.168.1.1 (IP interna de nuestro router) para que estas dos interfaces "comparta" las propiedades de esta interfaz virtual.

# conf term
(config)# bridge irb
(config)# interface vlan 1
(config-if)# no ip address
(config-if)# bridge-group 1
(config-if)# ip nat inside
(config)# interface BVI 1
(config-if)# ip address 192.168.1.1 255.255.255.0
(config-if)# ip nat inside
(config-if)# ip virtual-reassembly
(config)# bridge 1 route ip
# copy run start
# reload
+ El siguiente paso es configurar nuestro PC con una IP del rango 192.168.1.0/24 y conectarlo al router por la ethernet. Una vez conectado al router podemos abrir una ventana de DOS y hacer un "ping 192.168.1.1" para ver si ya llegamos al router. Si no llegamos es que nos hemos dejado algo.
+ El proximo paso ya es configurar la interfaz Wan de la ADSL. Para ello necesitaremos a mano los datos de conexión de nuestro proveedor. En mi caso Ya.com. Necesitaremos crear un dialer con los datos de la ADSL y añadir a la interfaz de ATM este dialer.
# conf term
(config)# interface Dialer0
(config-if)# ip address negotiated
(config-if)# ip nat outside
(config-if)# ip virtual-reassembly
(config-if)# encapsulation ppp
(config-if)# dialer pool 1
(config-if)# dialer-group 1
(config-if)# no cdp enable
(config-if)# ppp authentication chap pap callin
(config-if)# ppp chap hostname ad99999999@yacomadsl
(config-if)# ppp chap password 0 12345678
(config-if)# ppp pap sent-username ad99999999@yacomadsl password 0 12345678
(config)# ip route 0.0.0.0 0.0.0.0 Dialer0
(config)# access-list 1 permit 192.168.1.0 0.0.0.255
(config)# ip nat inside source list 1 interface Dialer0 overload
(config)# dialer-list 1 protocol ip permit
(config)# interface ATM0.1 point-to-point
(config-subif)# pvc 8/32
(config-if-atm-vc)# encapsulation aal5mux ppp dialer
(config-if-atm-vc)# dialer pool-member 1
(config)# interface atm 0
(config-ig)# no shutdown
# copy run start
# reload
Probamos desde el router hacer un "ping 194.179.1.100" para ver si salimos a Internet. Si no conseguimos respuesta miramos son un "show interfaces" si las interfaces de ATM se han levantado y con un "debug ppp authentication" si no validamos bien con el proveedor.
+ Por ultimo solo nos queda configurar el DHCP. Para ello configuraremo el DHCP en el rango 192.168.1.11 al 192.168.1.254. Nos guardaremos 10 direcciones IP estaticas.
(config)# no ip dhcp excluded-address 10.10.10.1
(config)# no no ip dhcp pool sdm-pool
(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.10
(config)# ip dhcp pool midhdcp
(dhcp-config)# import all
(dhcp-config)# network 192.168.1.0 255.255.255.0
(dhcp-config)# default-router 192.168.1.1
(dhcp-config)# dns-server 194.179.1.100 194.179.1.101
(dhcp-config)# lease infinite

9 comentarios:

Vicente LLorens dijo...

Hola desde ValenciA:

mE LLAmo Vicente y me han regalado un router Cisco 857 y no controlo los comandos de IOS, he intentado configurar el router desde pero no logro que acceda a internet. Mi proveedor es telefonica con Ip fija, IPOA y un gateway de salida fijo. Me podrias pasar l ventanas de configuración para este caso en particular?? Prometo invitacion fallas si funciona. Gracias.

Si necesitas mas datos te los pruedo proporcionar.

Vicente Llorens dijo...

Hola soy otra vez Vicente, s para decirte que el soft parA configurar el router es el propio de Cisco: SDM

Gracias de nuevo

amperis dijo...

Si quieres configurar tú ADSl con una IP fija tendrias que configurar tu interfaz ADSL (la ATM) como:

interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
bandwidth 8192
ip address A.B.C.D 9 255.255.255.192
ip nat outside
ip virtual-reassembly

pvc 8/32
encapsulation aal5snap
!
!

Luego si quieres que utilice el gateway de tu ISP basta con añadir la ruta:

ip route 0.0.0.0 0.0.0.0 F.G.H.I

Julio Alexis Espinosa Rivera dijo...

Hola soy alexis de Republica Dominicana donde vivo solo ahy un unico provedor adsl es claro codetel. Pero el servicio estanmalo pero bueno no ahy otra occion son los unico .loque quiero saver porque un sisco 850 dela serie 800 cadaves queloconecto mesaca por completo dela sentral y aunque conecte el viejo nosemeconecta borra toda la configuracion dela central yo le econtratado 6mega y solo cuando reinicio el TG585 v8 durante unos cuanto segundo funcionan los 6mega mas ya depues aunque aya una sola pc mequedan solo dos y tres mega pueden darme repuesta a eso .como entro en el puerto dela consola del sisco 850

Anónimo dijo...

Hola yo he leído algo de los módulos IOS 15 para la vic2-2fxo y el 1941W fxo en hwic no he visto nada.

Anónimo dijo...

Hola he visto que con el router Telnet TriplewaveSTB ya ponen la ONT en el router bueno yo gogleando he llegado a esta configuración hw creo que se llama para poner una tarjeta WAN en un router Cisco con fibra por ehwic un EHWIC-1GE-SFP-CU y dentro el Transciever que es la pieza de FTTH que ha de ser compatible con operador creo que es el GLC-BX40-U-I según indica Movistar con las prestaciones del router Telnet de arriba.

Anónimo dijo...

With cisco routers you need to save the configuration on a file because it's big and they do it with this method, normal web acces. And download the sys_backup.bin from remote support logs menu to insert on the router to can restore the SO firmware wth your configuration, directly without need to backp with the bkp file, router has more system than others adsl routers. Useful to upgradings.

Anónimo dijo...

PSTN-ruterVoIP-FXO-dmtf: yo se que cuando mides un teléfono con un tester salen 12 V bueno eso lo medí antes de la ADSL, creo que el dmtf lo que hace es aplicar una impedancia cuando se descuelga el telefono, es como si cerrase el circuito entonces en vez de 12 V hay unos 50 V, pues bien a mi me salia en el pstn line status algo de 12 V o 7 mA no recuerdo y ahora me dice 49 y 0 mA con hook state ON. Segun he leido hay que ponerlo en la configuración del ruter ADSL con VoIP ya que por ejemplo si en el fxs lo pones en forward en vez de reverse el descuelgue llamada lo hace la central y en reverse pasa por el fxo al servidor sip del ruter que luego va al fxs y lo pone en llamando o lo que sea. Hay otros valores que no se buscar en google PSTN Timer Values, PSTN Disconnect Detection, International Settings, regional ... es algo similar a las configuraciones PPPoA cuando empezó la ADSL tenias que buscar como iva en la red ya que paso a ip dinamica pppoe, etc... Entiendo que mi linea de teléfono no sabe configurarse sola con los parámetros dmtf telefonicos que me dan el tono de llamada creo que incluso se pone en modo reverse a veces y no me va, me gustaria saber cual son las configuraciones para España de todo esto, la configuración por defecto de fábrica del ruter para voz tampoco me dice cual es la de la central y no sabría conectarlo configurando des de 0 que es lo que busco ya que creo que como no sea así no va a ir tiene como 10 menús de configuración fácilmente restaurable ya que el ruter es un CISCO y la central no va ha cambiar. Tampoco sé como habilitar los parámetros de control en el ruter la voz viene completamente separada y necesito habilitarla en administración, estado, etc.

Anónimo dijo...

Asterisk con sipura, spa o srp.

Hola segun he probado puedes configurar un asterisk en varios modos de funcionamiento para acceder a el hardware por IP y así usar los telefonos: fxo, fxs, voip ...
Uno de ellos es el que hace que asterisk identifique una extension poniendo al hw un usuario y un passwd, y pasandole al asterisk la @ip del hw y el usr y passwrd, esto da visibilidad a los fxs con asterisk.
Otra manera es haciendo que asterisk sea el proxy, por tanto al hw le pasamos la ip del asterisk y la ponemos en proxy, le decimos que registre.
Según he leido estos aparatos de red, sólo aplican el dialplan al marcado del usuario, y ahí podemos indicar hacia a que host, interface mandar la llamada Ss([69]xxxxxxxx<:@asterisk>| ...) esto quiere decir que es algo parecido a llamadas salientes: dialplan saliente. En caso de una llamada entrante, o llamadas entre extensiones fxs, o etc, en caso necesario, no he encontrado ningún dialplan que me mande las llamas hacia asterisk, ya que un resgistro en un proxy, no tiene porque saber mis llamadas en la pstn, fxo, telefono normal de línea, es decir si le pongo un skype, no va a mandar las llamadas de mi línea a skype puesto que es otra línea, otro problema es que se suele perder el tono, hay configuración regional, reset de fáfrica, configuración de tonos, seguimiento de línea, asterisk, etc, que lo solucionan, yo lo desconozco. Me gustaria saber cual es el dialplan que envía las llamadas del fxo al asterisk, y el dialplan que manda las llamadas del asterisk al ruter, sip.conf, extensions.conf y el dialplan del ruter. Sigo buscando...